Upgrade PyLint to 1.4.4

Also remove hardcoded logilab-common dependency.  it was added because
pylint DEPENDS allows for the newest version of logilab-common, but astroid
(a pylint dependency) has a max dependent version of 0.63.0.

Change-Id: Iaba657585c3ef95833208cf3e0b15f4d3583ad99
1 file changed